If you use spreadsheets only for collecting data and creating graphs you are not taking full advantage of the power of spreadsheet software.  Designing interactive spreadsheets allows the teacher to create drill and practice and assessment worksheets and workbooks that reflect what is being taught and assessed in the classroom.  

Students type a response into a cell in an interactive spreadsheet.  The spreadsheet then evaluates this response against the teacher defined expected response.  If the interactive spreadsheet has been designed for drill and practice, the student receives immediate feedback and points.  

If the interactive spreadsheet has been designed for assessment, the student is given no feedback after entering a response.  The computer can calculate the score earned by the student and display the score after the student has responded to all questions.   

A portion of an interactive spreadsheet designed as drill and practice for fifth grade is shown in figure 1.
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Figure 1.  5th grade homophone drill and practice worksheet

Interactive spreadsheets are easy to create.  They employ the use of logic statements. Your interactive spreadsheets will become more sophisticated as you become more comfortable using logic statements.  Your first interactive spreadsheets may be fairly simple in design.

A logic statement "tests" a cell entry for specific information and then provides feedback based on the result of the "test".  The basic logic statement used in most interactive spreadsheets has the following format:

=IF(student cell reference= teacher cell reference,"positive feedback","negative feedback")

=: logic statements are entered as a formula into a cell of the spreadsheet.  All formulas begin with an equals symbol.  Forgetting to start your formula with an equals symbol is perhaps the most common mistake made.  If you see only your formula and not the result of your formula in the cell after you press enter, you have neglected to begin your formula with an equals sign.

IF: the beginning of the logic statement.  You are telling the computer you are setting a test for the contents of a cell.

(: don’t forget the parenthesis!  As you become more accomplished you may have several sets of parentheses for "nested" if, and, and or statements.

student cell reference: this is the actual name of the cell for which you are writing the "test".  This is the cell in which the student has entered the response to your question. The cell reference is entered in the column-row format.  If you are testing the information entered in column B, row 2, you would enter B2 for the cell reference.  It does not make any difference if you enter the letter as upper or lowercase, the computer will enter the letter reference as uppercase after you hit return/enter.

=: you must enter another equals symbol.  You are comparing the contents of student entered response to the teacher entered desired response. 

teacher cell reference: this is the location of the cell in the teacher enters the response expected from the student.  There are at least two limitations to expected responses.  First, the computer does not differentiate between upper and lower case letters; therefore, a test for proper nouns would not be appropriate unless written as a multiple-choice question.  The computer is looking for an exact match between the two cells (the cell where the student entered the response and the cell containing the teacher expected response); therefore, one or two word responses are best unless the student is entering the answer to a mathematical operation.  Again, if longer answers are expected, writing the question in a multiple choice format and expecting the student to simply enter a letter response may be the best "work around".

The portion of the logic statement student cell reference = teacher cell reference is called the logical test in Excel.

,: the comma separates the parts of the logic statement.  If you were to read the comma, the first comma can be read as "then".  If the contents of the cell equals the correct response, "then"…

"positive feedback":  this is called the value if true portion of the logic statement.  Place inside the quotes the response you want the student to receive if the he or she has entered the correct response into the cell.  If the logic statement is being used to award points for the correct response, the number of points is not placed in quotes.  The rule for using quotes is:  if you are entering text, place the text in quotes.  If you are entering a number and you want to perform an operation on that number (such as finding the total of all the points awarded), do not place the number in quotes.

,: the comma once again separates the parts of the logic statement.  The second comma could be read as "else" or "otherwise".  If the contents of the cell equals the correct response, "then", positive feedback, "otherwise" …

"negative feedback":  this is called the value if false portion of the logic statement.  Place inside the quotes the response you want the student to receive if he or she has entered the incorrect response into the cell.  If the logic statement is being used to award points for the incorrect response, the number of points (usually 0) is not placed in quotes.  The rule for using quotes is:  if you are entering text, place the text in quotes.  If you are entering a number and you want to perform an operation on that number (such as finding the total of all the points awarded), do not place the number in quotes.

): close the logic statement with a parenthesis.

Examples of Specific Logic Statements With Explanations

=IF(B2=E2,"Wonderful","Try Again")


If the student entered answer in cell B2 is the same as the teacher entered expected response in cell E2, the student will see the word Wonderful in the cell where this formula was entered, otherwise the student will see the words Try Again in the cell.

=IF(B2=E2,10,0)


If the student entered answer in cell B2 is the same as the teacher entered expected response in cell E2, the student will see 10 points awarded in the cell where this formula was entered, otherwise the student will see 0 points awarded.

Using a cell for the teacher entered expected response makes writing the logic statements less cumbersome.  It also makes "filling down" the formulas much easier.  You will be less likely to make mistakes in formula entry when you are able to use the fill down function.  If you do not want to use a cell reference for the correct response you can enter the correct response into the logic statement.  In this case, the logic statement is as follows:

=IF(B2="nonliving","Wonderful","Try Again")


In this case, the response the student should have entered in B2 is nonliving.  If the student entered nonliving, the feedback cell will display Wonderful; if the student did not enter nonliving, the feedback cell will display Try Again.
=IF(B2="nonliving",10,0)


If the student entered nonliving in cell B2, 10 will be displayed in the cell where this formula was entered; otherwise, 0 will be displayed.

Now that you have been introduced to the basics, let’s create a simple interactive spreadsheet in Excel.  This spreadsheet will be designed for first grade as a drill and practice compound words worksheet and then copied and modified for an interactive test.  Both spreadsheets will total points earned and will be part of the same Excel workbook. 

· Open Excel.  This Excel workbook will use two worksheets.

· Format the font and font size for five columns (for first grade I like to use d’nealian, modern, or comic sans and size 18).

· Format columns A, B, and E to width of 20.

· Format columns C and D to width of 10.

· In cell A1 type Words (this column will be used by the teacher to enter words for combining to make a compound word).

· In cell B1 type Compound Word (this column is where the student will enter the compound word).

· In cell C1 type Right? (this column will provide positive or negative feedback to the student; if the spreadsheet is used as a test, you will later hide this column).

· In cell D1 type Points (this column will display points earned for the student’s entry; if the spreadsheet is used as a test, you will later hide this column).

· In cell E1 type Expected (this column is used by the teacher to enter the correct, expected student response; you will later hide this column from the student).
· Set the alignment for row 1 to center alignment and choose green for the font color of the words in row 1.
· Save your workbook as compound.xls
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· In cell A2 type fire + place.

· In cell B2 and E2 type fireplace (fireplace in cell B2 is used for testing purposes only; this cell will be blank when you are finished).
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· In cell C2 enter the test for the student response:
· =IF(B2=E2,"Good","Uh-Oh")
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· Press return (enter); if you see the word Good in cell C2 you have correctly entered the formula.
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· In B2 type firplace.  Uh-Oh should now be displayed in the Right? column.
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· Now, delete firplace from B2.  Unfortunately, Uh-Oh is still displayed.  The logic statement can be modified so the Right? cell is blank until the student enters a response.  
· Modify the logic statement in C2 to read:
=IF(B2="","",IF(B2=E2,"Good","Uh-Oh")) Type the quotes with no spaces between them.  This logic statement says if B2 is blank ("") then leave C2 blank (""), otherwise if B2=E2, display Good, otherwise display Uh-Oh.  Test your formula by typing both correct and incorrect responses into B2.  Be sure to leave the cell blank when you are finished.  These statements are called nested IF statements because they contain more than one IF statement.  Seven IF statements is the maximum number that can be nested.

[image: image7.png]A [ B I C I D I E
Words  Compound Word | Right> Points  Expected
2 |fire + place fireplace




· Using this same procedure, add nine more compound words to the spreadsheet.  Be sure to save frequently.  Copy the formulas by using "Fill" > "Down" from the Edit menu.
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· Test the spreadsheet to make sure the logic statements are working correctly for Right? feedback column.

· Now it is time to enter points into the Points column.  This also uses a logic statement.  If the student entered response in the B column is equal to the teacher entered expected response in the E column, the student should receive 10 points if this worksheet is based on 100 points.  The number of points should not appear until the student has actually entered a response.  The formula is: =IF(B2="","",IF(B2=E2,10,0))  Notice there are no quotes around the numbers.  This is because we want to treat these numbers as numbers and not as text.
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· Test the spreadsheet to make sure the logic statements for the Points column are working correctly.

· Add a final row that will give the total number of points earned for this worksheet.  The formula to be entered in D12 is: =Sum(D2:D11).
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· Now hide column E by highlighting the column and choosing Format > Column > Hide.

· Double-click on the Sheet1 tab at the bottom of the worksheet and change the name of the tab to Practice.
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· To make the spreadsheet easier to read, change the color of every other row.  Highlight the cells in row 2.  Choose Format > Cells > Patterns > Choose a pastel color.  Skip a row.  Highlight the cells in row 4.  Use  Y keystroke to repeat the color format for the cells.  Cell borders are no longer visible in the rows that have been shaded.  

· Highlight the cells in the spreadsheet.  Choose Format > Cells > Border > Choose Outline and Inside.
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